Caterpillar EP16KT:
EP16KT: error code 23 no forward or reverse

Hello,

I have a Cat Ep16KT (serial ETB4A25617) which has recently stopped moving forward or reverse. After a short period of showing codes 10 and 20 but working fine after a 20min break, it has stopped completely, showing code 23.

Basically I can start the forklift by key (line contacter is activated), I can put the forward/reverse control in gear (everything is fine so far) but once I hit the gas pedal, everything shuts down and shows code 23 on the display.

The drive contactor (next to the line) is not being activated where it used do this before.

my wild guess is some sort of a shortcut.

already replaced: all brushes, gaspedal potentio meter.

Any suggestions is highly appreciated as we can't find a local Cat mechanic.

Full electrical schemes and/or workshop manual is also highly appreciated

Neal
  • Posted 13 Aug 2019 01:20
  • Modified 13 Aug 2019 01:27 by poster
  • Discussion started by Neal_A
  • Limburg, Belgium
Showing items 1 - 3 of 3 results.
so this morning had another look at the print and made an attempt to solder the resistors back. didn't make any difference but one got so brittle it broke off. Will get them replaced next week. Acc to my measurements they are both 17-18 ohms at 2Watt (the blueish one is 15 ohms at 2 Watts (its still visible on that one. on the white ones it has burned of... (if someone has other/more detailed info on these, please share)

I assume it's part of the problem. Wether it is a reason or consequence of something else is not yet clear.

My drive print has a sticker on the back saying " QA-tested 03-15-13"
considering it's a 2000 forklift, this one has already been replaced before...
  • Posted 24 Aug 2019 19:31
  • Modified 24 Aug 2019 19:33 by poster
  • Reply by Neal_A
  • Limburg, Belgium
Contact : info@4-motion.eu
I dug a bit deeper into the issue with my forklift and decided to look at the drive print. On the front side you can see 3 white/blueish resistors/transistors. I found the 2 white ones to be very loose on the board. Looking at the back you can see that there is somewhat of a burn mark where they are soldered to the print. I can wiggle them around by hand but I can't just pull them out.

I figured a bad contact could be the issue here so I turned the ignition on a few times and tried the pedal. Issue still remained. After that I tried to wiggle these resistors once more by hand and found the outher white one to be cold and the middle one to be extremely hot ( I burned my thumb on it).

Could this be an indication to something?

Any way to put some pictures on here?
  • Posted 24 Aug 2019 19:27
  • Reply by Neal_A
  • Limburg, Belgium
Contact : info@4-motion.eu
Having the same problem with a ep18kt. if you figure out what's going on please post your findings. Thanks
  • Posted 20 Aug 2019 20:23
  • Reply by Rcarter
  • North Carolina, United States

Having trouble using the Discussion Forums? Contact us for help.

Forkliftaction.com accepts no responsibility for forum content and requires forum participants to adhere to the rules. Click here for more information.