Hyster E80V:
melted connectors

This unit has melted two sets connectors. I've checked the battery settings for a 1350 amp rated battery and they are set correctly at 2.12 full charge and 2.00 for discharge. battery specific gravity is at 1290 +/- 10 per cell. The main contactor is operating freely, the PTC checked good. I've replaced the cables, connectors, and contactor. However, it melted another set. Is there anything I'm missing?
  • Posted 19 Feb 2020 11:32
  • Discussion started by Midnight
  • Louisiana, United States
Midnight
Showing items 1 - 1 of 1 results.
Motor insulation, have you got a short?
  • Posted 19 Feb 2020 20:55
  • Reply by andrew_k
  • England, United Kingdom
andrew_kershaw@msn.com

Having trouble using the Discussion Forums? Contact us for help.

Forkliftaction.com accepts no responsibility for forum content and requires forum participants to adhere to the rules. Click here for more information.

Movers & Shakers

CEO - Region Americas
DB Schenker, United States
president and CEO
Seegrid Corporation, United States
Chairman
National Road Transport Association, Australia
CEO
Beumer Group, Germany

Movers & Shakers

CEO - Region Americas
DB Schenker, United States
president and CEO
Seegrid Corporation, United States
Chairman
National Road Transport Association, Australia
CEO
Beumer Group, Germany

FOR SALE ON MACHINERY-ONQ

Xilin CPD20SA20
United States Pennsylvania
Canada Ontario

In the Discussion Forums

- Iqra_Bashir, United Arab Emirates

Movers & Shakers

CEO - Region Americas
DB Schenker, United States
president and CEO
Seegrid Corporation, United States
Chairman
National Road Transport Association, Australia
CEO
Beumer Group, Germany