Hyster H100XM:
Impco Spectrum II Trouble Code Description

Hello to the group, new guy here looking for some appreciated help. I have a 2004 Hyster H100XM with 4.3 LPG engine with Impco Spectrum II engine controls. I need the code descriptions. I have searched internet and bought service manual for this machine, but the Spectrum Codes are not the same as. Thanks in advance for any assistance !


Ser# L005V01745B
  • Posted 5 Feb 2023 02:50
  • Discussion started by matthew_mann
  • Louisiana, United States
Matt Mann
Showing items 1 - 12 of 12 results.
Update on this project for all who chimed in. I was able to locate a NEW Spectrum II 56 pin ECM from Eric @ Carb and Turbo in Shakopee MN. No more intermittent no fire.
  • Posted 19 Mar 2023 03:38
  • Reply by matthew_mann
  • Louisiana, United States
Matt Mann
Hello friend, could you please help me to find the meaning of code 150 and 153 for a yale forklift model FB20PYE... it is not easy but if you try i will appreciate a lot. thank you
Max
Hope that has it. The next thing I would install is a harness. Good luck.
  • Posted 21 Feb 2023 04:15
  • Reply by garland_m
  • Virginia, United States
Work Hard and Fish Long
@ Garland, Thanks for the input. No codes tripped with the no fire situation. I would expect the same if it was missing an input signal.

@ Scott, I have been leaning towards a ECM. Prior to it arriving at my shop they (previous shops) threw parts at it. Cap, Rotor, Wires, ECM, Fuel S/D valve, Pressure Regulator, You name it. Originally I found the dash was shutting it down on high torque converter temp (30sec after start). I made the dash happy and then we got into the intermittent fire issue. After finding multiple harness issues, mainly the wire almost cut in half for ECM pin 10, to the field coil on "power supply relay" I thought I had something. Cleaned up harness, found ground strap at right engine mount extremely loose, added a battery to chassis 4 AGW cable in addition to the battery to engine 2AWG. At this time it has been starting all day after cleaning ECM connector with a full can of "CRC Electronic Cleaner"......fingers crossed.
  • Posted 20 Feb 2023 12:54
  • Reply by matthew_mann
  • Louisiana, United States
Matt Mann
Matthew it's Scott l read your problem now l ran into the same problem about 6years ago with a cat with a 4.3 gm tier 2 Spectrum system could not get spark at times. l know you said it has a reman ecm in it but some of them were not good they used resistor that were not automotive in side and would fail it would lead to no spark at times if you can l would send it to a company called flight systems and have it checked or get a new one from dealer. it was pot luck on reman ecms.
  • Posted 20 Feb 2023 11:22
  • Reply by Scott_
  • Pennsylvania, United States
Scott
Matthew,

We had a hard time finding cords to complete connections with the spectrum system. When it is right it is good, but it can drive you crazy. When you come across the no start, do you read any additional codes? Check distributor close, cap, rotor, wiring and connections. I have seen the rotor failing causing something similar. Normally if the ECM is missing something a code will show. I retired last year and do not have a lot of info to look at. Sorry
  • Posted 20 Feb 2023 10:37
  • Reply by garland_m
  • Virginia, United States
Work Hard and Fish Long
This unit was a mess. I have pulled the engine harness and made repairs where needed. I have added grounds in needed areas. The new TMAP did fix the engine codes, its clear now. I still have a intermittent no fire. Cam/Crank pulse with is good back to ECM. This machine has had a RE-man ECM, New Coil, Ignition Module, Cam & Crank Sensors, Point to point OHM out of every pinned ECM to connector. Its been a real challenging machine. It will run perfect, multiple starts, turn it off, go for a start, crank.....no fire. Power control relay makes and energizes systems as it should. Any ideas would be great. I need a data patch cord so I can see what the ECM is missing.
  • Posted 20 Feb 2023 06:05
  • Reply by matthew_mann
  • Louisiana, United States
Matt Mann
Matthew,

If the sensor did not fix the problem, check the ground strap under the distributor to ensure it is clean and tight. Have you had any problem with battery, jump starting? May need to check alternator, low voltage in system causes all sorts of problems. Good luck and let us know what you find. Thanks
  • Posted 14 Feb 2023 05:42
  • Reply by garland_m
  • Virginia, United States
Work Hard and Fish Long
Thanks, I will go check it out.
  • Posted 6 Feb 2023 08:54
  • Reply by matthew_mann
  • Louisiana, United States
Matt Mann
Ok code 132and 135 are both talking about you have a problem with the bosch tmap sensor 132 said low voltage to map and 135barometric pressure low to tmap.l would check all wiring sensor ground is #49 at ecm to #1 a tmap color of wiring is black with Lt green stripe #32at ecm is IATsignal to #2to. Tmap tan wire #50 at ecm is 5volts to #3 at tmap wire is Lt green with red stripe last is map signal #33at ecm to #4 at tmap wire is Lt green check all connection and wiring if no problem l would install a new tmap and see if code cleared if not there could be a problem in ecm but check first. Hope l was of help.
  • Posted 6 Feb 2023 08:33
  • Reply by Scott_
  • Pennsylvania, United States
Scott
132 and 135 are current codes. I have the software installed on laptop but cant get the patch cord through my local Impco dealer. I jumped out the diagnostic connectors
  • Posted 6 Feb 2023 03:33
  • Reply by matthew_mann
  • Louisiana, United States
Matt Mann
I can try to help you first have you have the software to go into the truck and if not are you able to blink the light to get the codes if so the codes are all three digits if you need to know what the code is for let me know and l will look it up for you and post it.if you can't get into the truck let me know and l will tell you how to blink the light to get the code. Hope this helps
  • Posted 6 Feb 2023 02:35
  • Reply by Scott_
  • Pennsylvania, United States
Scott

Having trouble using the Discussion Forums? Contact us for help.

Forkliftaction.com accepts no responsibility for forum content and requires forum participants to adhere to the rules. Click here for more information.

Latest job alerts …
Louisville, Mississippi, United States
Indianapolis, Indiana, United States
Tampa Florida, United States
Greenville, North Carolina, United States

PREMIUM business

TVH Headquarters
All parts and accessories for material handling, industrial vehicles, and construction and agricultural equipment.
Fact of the week
Despite spending half his career in the saddle, Clint Eastwood is allergic to horses. It was reported that Eastwood tried to limit his time around horses. In the films he directed, he would try to complete scenes involving horses in one take.
Moffett M55
Flesherton, Ontario, Canada
Used - Sale
Still RC40-35
Hornweg, Netherlands
Used - Sale
Global Industry News
edition #1175 - 18 April 2024
With companies large and small seeking to reduce their carbon footprints, most of the attention has so far focussed on direct carbon emissions... Continue reading
Movers & Shakers
R. Mark Cox R. Mark Cox
Senior Vice President Corporate Development, Terex
Chief Financial Officer, Toyota Material Handling North America
Chief Operating Officer, Carolina Handling
Vice President of Sales - Americas, TVH Americas