Hyster S60FT:
Trouble Starting Forklift

I have a 1986 Hyster 60 that runs well but has some trouble starting. We have found that it starts if you lift the top of the Impco model 100 mixer and let a little bit of air in below the diaphragm. We replaced the diaphragm on the mixer and cleaned it out. It still has the same problem with a new diaphragm but it still has the same problem. I have done a lot of trouble shooting on the issue, but I think I am missing something on the troubleshooting. Does anyone know what might be causing this issue?
  • Posted 14 Oct 2020 07:15
  • Discussion started by Chris_Moreno
  • California, United States
Showing items 1 - 1 of 1 results.
Is it a 60XL? It sounds like a rich running condition to me. I suggest investigating the regulator. The diaphragms are known to get small pin holes or even a tear which leads to way too much fuel getting to the engine. I hope this helps.
  • Posted 17 Oct 2020 04:09
  • Reply by LCNIII
  • North Carolina, United States

Having trouble using the Discussion Forums? Contact us for help.

Forkliftaction.com accepts no responsibility for forum content and requires forum participants to adhere to the rules. Click here for more information.

Global Industry News
edition #1146 - 21 September 2023
There could be an against-all-odds movie made about two people in the news this week... Continue reading
Upcoming industry events …
November 28 - 29, 2023 - Singapore, Singapore
December 6, 2023 - Online, Australia
February 26 - 29, 2024 - Dubai, United Arab Emirates
Movers & Shakers
Scott Young Scott Young
Head of Sales North America, Volvo CE
Vice President of Sales, Tompkins Solutions
Chief Operating Officer United States and Canada , Swissport
President, Volvo Penta