Hyster E50XL:
Ramp Start

I have a Hyster E50 XL 48 volt EV-100, that will not back out of a trailer or start up an incline from a dead stop. Items that have been checked/replaced are : Drive Motor, Start Switch, Potentiometer, Traction Card (all settings verified at factory parameter) conductor, all contactors assys are in good working order. Battery is fully charged and in good working condition. The lift will take off fine on level surface, just not on incline. Any suggestion would be greatly appreciated. Thanks!
  • Posted 12 Jul 2011 23:02
  • Discussion started by Smoke
  • Tennessee, United States

Having trouble using the Discussion Forums? Contact us for help.

Forkliftaction.com accepts no responsibility for forum content and requires forum participants to adhere to the rules. Click here for more information.

Global Industry News
edition #1179 - 16 May 2024
This week we bring news of big industry players expanding their companies with cross-border acquisitions and investments... Continue reading
Upcoming in the editorial calendar
DIGITISED STOCK CONTROL AND FORKLIFTS
May 2024
PRODUCTION OF MATERIALS HANDLING EQUIPMENT IN NORTH AMERICA
Aug 2024
Upcoming industry events …
May 30-31, 2024 - Singapore, Singapore
June 11 - 13, 2024 - Rotterdam, Netherlands
October 23-25, 2024 - Ningbo, China
Taylor T650L
Coraopolis, Pennsylvania, United States
Used - Sale & Hire
SMV (Konecranes) SL28-1200A
Hornweg, Netherlands
Used - Sale

Showcased in the Virtual Expo

Global Industry News
edition #1179 - 16 May 2024
This week we bring news of big industry players expanding their companies with cross-border acquisitions and investments... Continue reading
Fact of the week
In a room of just 23 people, there is a 50/50 chance that at least two people have the same birthday. In a room of 75 people, there's a 99.9% chance of at least two people matching.