Hyster S30A:
TRANS DON'T WORK AFTER FLUID CHANGE

I have changed the spin-on filter and topped off new trans fluid and the trans don't work. I can't find the screen filter. The trans work fine before the change. Is there a line I need to Purge?? This forklift have the "Forward/Rev Gas Pedal".
  • Posted 27 May 2016 03:42
  • Discussion started by 808FORKLIFT
  • Hawaii, United States
Showing items 1 - 1 of 1 results.
Could it be the switch on the parking brake that deactivates the trans?
  • Posted 27 May 2016 07:22
  • Reply by mrfixit
  • New York, United States

Post your Reply

Forkliftaction.com accepts no responsibility for forum content and requires forum participants to adhere to the rules. Click here for more information.

Having trouble using the Discussion Forums? Contact us for help.

More electric firsts for Brazilian port Recife Metropolitan Area, Brazil
Upcoming industry events …
September 4, 2024 - Blair Athol, South Australia, Australia
October 9-10, 2024 - Houston, United States
October 21-22, 2024 - Riyadh, Saudi Arabia
More electric firsts for Brazilian port Recife Metropolitan Area, Brazil
Movers & Shakers
Michael Oren Michael Oren
Senior Vice President of Sales for the Americas, Dematic
Director of Membership, Lifting Equipment Engineers Association (LEEA)
Chief Operating Officer, Vecna Robotics
Executive Vice President, Port Solutions, Konecranes
Upcoming industry events …
September 4, 2024 - Blair Athol, South Australia, Australia
October 9-10, 2024 - Houston, United States
October 21-22, 2024 - Riyadh, Saudi Arabia
Movers & Shakers
Michael Oren Michael Oren
Senior Vice President of Sales for the Americas, Dematic
Director of Membership, Lifting Equipment Engineers Association (LEEA)
Chief Operating Officer, Vecna Robotics
Executive Vice President, Port Solutions, Konecranes